Error actualización package-query: error while loading shared libraries: libalpm

  • Archrysler
  • Avatar de Archrysler Autor del tema
  • Conectado
  • Navegador Iniciado
  • Navegador Iniciado
Más
2 años 7 meses antes #1

Hola:

Si a alguien le da ese error porque package-query fue instalado de forma indirecta al instalar yaourt .
Me imagino que en breve será actualizado , pero de momento yaourt queda inservible.

Si alguien quiere solucionarlo de forma inmediata la solución es sencilla --o debería de serlo para un usuario de Arch-- y es clonar directamente package-query desde la fuente y listo.

¿Cómo se hace?

Abrimos terminal :

git clone https://aur.archlinux.org/package-query.git
cd package-query/
makepkg -si

Y cuando volváis a actualizar o usar yaourt ya tendréis todo operativo.

Todo esto es porque el package-query pide la librería libalpm.so.10 y el sistema ha actualizado a libalpm.so.11

Saludos.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

  • sr_kenobi
  • Avatar de sr_kenobi
  • Conectado
  • Navegador Experto
  • Navegador Experto
  • ~# /usr/bin/zsh
Más
2 años 7 meses antes #2

Siempre lo he hecho descargandome el tarball, descomprimir y makepkg -risc, si cambia versión o se actualiza pacman, edito el PKGBUILD y a tirar, nunca usando git.


I'm not anti-social, I'm just not user friendly • GNU/Linux user • Informático en el averno • There's no place like 127.0.0.1 • Jabber → Esta dirección de correo electrónico está siendo protegida contra los robots de spam. Necesita tener JavaScript habilitado para poder verlo.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

  • Archrysler
  • Avatar de Archrysler Autor del tema
  • Conectado
  • Navegador Iniciado
  • Navegador Iniciado
Más
2 años 7 meses antes #3

Hola:

Pero hay mucha gente que lo hace desde archlinux.fr añadido al /etc/pacman.conf.

Y son ellos los que más sufren esto , incluso aquellos que tienen basadas o derivadas de Arch como Antergos o Manjaro.

Por eso lo puse así.

Saludos.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

¡Atención! Este sitio usa cookies y tecnologías similares.

Si no cambia la configuración de su navegador, usted acepta su uso. Saber más

Acepto

Vea nuestra política de cookies y enlaces de interés aquí